Ultimi ascolti...

mauro paternò?!

19 ottobre 2008

Ubuntubook!

[EDIT: now there is a raw, homemade english version of this post if you read further, after the original in italian ends. Have a nice reading!]

Dopo settimane di febbrile analisi delle varie offerte disponibili, dopo aver controllato per intero pagine e pagine di forum di utenti sui vari notebook (certe discussioni giungono alla bellezza di 160 pagine!) mi sono deciso all'acquisto di un computer Compaq Presario CQ60-103EL. Posto qui la mia esperienza con questa macchina per gli altri Ubuntu users che avessero bisogno di chiarimenti prima di acquistare questo portatile.
Il notebook è carino, lo schermo è stranamente da 15,6” e non da 15,4” come in tutti gli altri notebooks della sua categoria, ha una tastierina numerica sulla destra accanto alla tastiera da notebook, compatta e non rumorosa. Ottima risoluzione dello schermo, anche piuttosto luminoso, il problema è che il sistema operativo fornito, il famigerato Windows Vista Home Basic, è purtroppo all'altezza della sua fama. Poche le innovazioni introdotte con questo sistema operativo rispetto ad XP; in compenso è piuttosto lento, mangia un sacco di risorse anche in idle e giunge al consumatore pieno di applicazioni di terzi, tutte in prova e che chiedono, con una certa insistenza, di essere acquistate. C'è anche l'immancabile suite per la sicurezza da virus Norton di Symantec, comprensiva di LiveUpdate: solo per disinstallare quella il pc è rimasto a macinare per diversi minuti...
Insomma, un po' lo sapevo, visto che mio padre aveva acquistato un notebook l'anno passato e mi ero davvero stupito della lentezza di quel sistema operativo e degli altri inconvenienti. Ma io l'ho preso per installarci Ubuntu, dato che è un sistema operativo open source, freeware e stabilissimo, per di più con una comunità che fornisce un ottimo supporto (invidiabile anche per i sistemi operativi commerciali)
quindi... ho relegato Vista in 40GB di partizione grazie all'ottimo cd di installazione di Ubuntu v. 8.04 (versione 64 bit) e ho "piallato" il resto, mettendoci la mitica Hardy, che entro fine mese sarà rimpiazzata dalla nuova Intrepid Ibex.
La scheda video funziona con i drivers proprietari Nvidia che, come è ormai consueto, sono stati scaricati automaticamente da Ubuntu e installati
senza problemi. Quindi ho potuto utilizzare da subito Compiz, cubo e altri effetti eyecandy compresi, senza alcuna difficoltà.
Anche la webcam funziona senza problemi, va sia con Cheese, sia con Skype, niente da fare invece per Camorama - "could not connect to video device" è il verdetto inappellabile, che avevo già avuto per una webcam Philips sul mio pc desktop. Ma per quello che mi serve funziona.
L'unica cosa che ha dato qualche problema è stata la scheda wireless. Si tratta di una Atheros AR5007, molto nota nei blog in rete per questo inconveniente, comunque la soluzione è segnalata da numerose fonti (ad esempio, qui) e con un minimo di smanettamento la scheda wireless può funzionare. Uniche pecche: il tastino per escludere il funzionamento del touchpad e l'altro tastino per attivare/disattivare la scheda wireless non funzionano. Ciò comporta che il touchpad sia sempre in funzione, con qualche inconveniente saltuario a causa di sfioramenti involontari durante la videoscrittura - verificatisi anche nel corso della redazione di questo post ;-) - e comporta anche
che il funzionamento della scheda wireless non possa essere escluso se non via software.
Anche l'entrata in funzione della scheda wireless all'avvio del sistema operativo non è rapidissima come in Vista (dove, diamo a Cesare quel che è di Cesare, ancora prima dell'avvio del gestore grafico è già funzionante e agganciata alla rete) e bisogna aspettare un minuto o due prima che sia completamente operante. In più, la spia della stessa è sempre arancione (che vuol dire che la scheda non funziona) anche quando è tutto ok, mentre in Windows quando si aggancia alla rete la spia diventa blu.
In più, non funzionano le funzioni di sospensione ed ibernazione del sistema... purtroppo.
Tutti inconvenienti di minima entità e del tutto trascurabili, di fronte alla possibilità di avere sul proprio notebook Ubuntu v. 8.04, un sistema operativo pienamente personalizzabile, leggero e, quel che più conta, stabile, parco nelle risorse richieste alla macchina per girare.
Che si può volere di più dalla vita? Magari l'interfaccia tipo Leopard e un set di icone figo come Hydroxygen di Deviantdark... per fortuna sono ambedue installabili smanettando per qualche minuto.
E adesso mi ritrovo con un meraviglioso Ubuntubook, che mi accompagnerà in mille avventure!

[AGGIORNAMENTO: Avendo pasticciato un po' con la condivisione in rete locale della home del notebook, ho incasinato i permessi al punto che non riuscivo più a riavviare una mazza... Visto che nel frattempo è uscita anche la Ubuntu 8.10, ho installato direttamente questa versione.
L'installazione è semplice, come con la versione precedente. Per l'attivazione della scheda wireless, la procedura è un po' diversa da quella messa in link sopra, ma, al solito, basta cercare un pochino su google e tutto si risolve in un minuto. Gli inconvenienti con i tasti di attivazione/disattivazione del touchpad e del wireless permangono, mentre la sospensione e l'ibernazione del sistema adesso funzionano senza problemi. Buon Ubuntu a tutti...]

[Ulteriore aggiornamento al 03/06/2009: posto ancora perché magari può servire, vedo che questa pagina è ancora molto vista e da tutto il mondo, per giunta, pensa te che successone! Anyway, con il rilascio di Ubuntu 9.04 Jaunty Jackalope ho deciso di fare una reinstallazione da zero di tutto il sistema operativo, formattando tutte le partizioni ad esclusione della /home, il cui contenuto, pertanto, è rimasto invariato, compresi i file di configurazione. Non so se è per questo motivo - avere conservato i file di configurazione - ma al primo avvio
tutto funzionava, scheda wireless Atheros inclusa, senza bisogno di pasticciare in alcun modo. Ripeto, non sono in grado di capire se si tratti di un miglioramento della distribuzione o di un beneficio derivante dall'avere utilizzato la stessa home con le configurazioni già presenti in Ubuntu 8.10 Intrepid Ibex, nel primo caso si tratterebbe di un risultato ragguardevole, non vi pare?]

ENGLISH VERSION:

After spending weeks in analyzing all the commercial offers, after checking pages and pages of forum pages concerning notebook models (some threads are even 160 pages long!) I decided to buy a Compaq Presario CQ60-103EL.
I write about my experience here, in order to let other Ubuntu users know how this distribution will work on this notebook before buying it.
The notebook is nice, the display is, strangely, 15.6” and not 15.4” as the displays all other notebooks have, it has a little numerical keyboard on the right of the standard notebook keyboard, that’s compact and not noisy. The display has a very good resolution and it’s really bright, the problem is that the OS, the well known Windows Vista Home Basic, has all his well known problems. The new features of this OS are few, but it’s slower than XP was, it eats a lot of system resources even in idle state and it comes with a lot of third party programs, all shareware, always asking you to be buyed with annoying banners. There’s also the Norton antivirus suite, with Live Update too: it took several minutes only to uninstall this one…
Anyway, I already knew it, because my father last year bought another notebook that came with preinstalled Vista and I was really astonished by the slowness of that OS. But I bought it in order to install Ubuntu on it, because it is an open source, freeware and very stable OS that has a backing community offering the best support (even better than the one you can find for a lot of commercial OS) so… I jailed Vista in a 40 GB partition thanks to the great Ubuntu v. 8.04 (64 bit version) installation cd and I formatted the rest, installing on the new partition the mythical Hardy, that within the end of the month will be replaced by the newer Intrepid Ibex.
The video card works with the proprietary drivers provided by Nvidia, that, as usual, have been automatically downloaded and installed by Ubuntu with no issue at all. So I could soon use Compiz, including the cube and all the other eyecandy effects, with no problem.
The webcam works good, it works with Cheese and Skype, but not with Camorama – “could not connect to video device” is the irrevocable verdict, the same I already received for a Philips webcam I installed on my desktop pc. But it fits for my needs.
The only thing that gave me problems was the wireless device. It is an Atheros AR5007, very famous on the net for its issues with Linux, but the solution can be found in a lot of sites (here, as an example) and it works, after some trouble.
The only issues: the touchpad on/off button does not works, just as the on/off wireless button. This causes the touchpad to be always on, with some occasional drawback dued to unintentional skimming and it causes the wireless module to be always working too, in can be disabled only by software. The full operation of the wireless device is not as fast as in Windows Vista (I have to admit it), and you have to wait some seconds to have it fully active. The wireless light is always on orange (that means that the device is not working) even when it’s ok, while on Windows when the device is ok it turns to blue.
Furthermore, the hibernate system and suspend system functions don’t work, unfortunately.
They’re all unimportant issues, compared to the possibility to have Ubuntu 8.04 on this netbook, a light, fully customizable and, most of all, stable OS, that doesn’t ask much system resources in order to work.
What could someone want in addition?
Maybe a Leopard-like interface and a cool iconset like Hydroxygen by Deviantdark… luckily, they’re both installable for free, with a little work.
Now I have a wonderful Ubuntubook, which will drive me in a thousand adventures!

[UPDATE: Doing some odd stuff in order to share my home folder on my local net, I messed up all the permissions and the system didn’t start anymore. Because, in the meantime, Ubuntu 8.10 had came out, I installed on my Ubuntubook this new OS version. Installing is as easy as it was on the older version, for the wireless device the procedure is a bit different than before, but, as usual, it takes a while to find with Google the right advice to have it working. The issues with the touchpad and wireless on/off buttons still exist, while the suspend and hibernate functions now are working out of the box. Good Ubuntu to everyone…]

[Further update, 06/03/2009: I write again because maybe someone will appreciate it, I’ve seen that this page is still being visited, from all over the world, too, what a success! Anyway, after Ubuntu 9.04 Jaunty Jackalope came out, I decided to reinstall all the OS from scratch, formatting all the partitions except /home, whose content, then, remained unchanged, configuration files included. I don’t know if this is the cause, but everything worked out of the box, wireless device included (not on/off buttons I wrote about before), with no need to work on it at all. I’m not able to know if the cause of it has been having preserved the configuration file from the previous installation of Ubuntu 8.10 Intrepid Ibex, or if it’s an improvement of the distribution. In the latter assumption, it would be a remarkable improvement, wouldn’t it?]

, , , .

6 commenti:

silvano ha detto...

sto provando a scaricare i driver proprietari della scheda video, mi da'

W: Failed to fetch http://security.ubuntu.com/ubuntu/pool/restricted/l/linux-restricted-modules-2.6.24/nvidia-glx-new_169.12+2.6.24.13-18.41_i386.deb
404 Not Found

mentre i driver del wireless atheros sono
attivi - ma non l'ho ancora provata.
mi devo preoccupare.....?!

mauro_paternò, of course! ha detto...

Stranissimo, a me è andato tutto ok. I drivers proprietari della scheda video sono stati scaricati utilizzando l'utility presente in Sistema--->Amministrazione--->Gestore driver con restrizioni.
Quelli della scheda Atheros io li avevo abilitati sempre da là, ma così non funzionavano.
Li ho quindi disabilitati e ho seguito la procedura descritta sul link riportato nel mio post. Anche qui c'è la procedura, in italiano per sistemi a 64 bit come il mio: http://www.nexal.it/blog/?p=6
Forse c'è una qualche interazione nefasta fra drivers Atheros e Nvidia?
In fondo a quella pagina si dice:
NOTA: nel caso riscontraste problemi durante la connessione alle reti wireless, in particolare se doveste abilitare i driver nvidia dopo la suddetta procedura, assicuratevi di deselezionare Atheros HAL e support for Atheros 802.11 wireless da Sistema>Amministrazione>Driver Hardware.
___________

Non sono uno smanettone, quindi non saprei che consigliarti se i problemi continuano. Fai le tue prove, se non risolvi ti consiglio di fare come faccio di solito: ricerca sul forum di Ubuntu.it e, se non trovi niente, apri come extrema ratio un topic apposito.
Ciao!

silvano ha detto...

ok, dopo vari giorni sono riuscito a far
girare *quasi* tutto (tranne ovviamente la wireless...), ma ci e' voluta la versione stabile di intrepid uscita il 30. io smanetto piu' volentieri in moto che davanti a un pc, ma mi sono dovuto mio malgrado rimboccare le maniche.....
nell'ordine ho fatto questi tentativi
di istallazione da live CD (forse
tutto questo non serve piu' a nessuno, ma lo lascio per curiosita'):
- 8.04 i386, installa na non vede il video
- 8.10 beta 32bit, errori v86d e VBE, errore I/O su dev/sr0, poi si blocca su
initramfs
- 8.10 beta alternate 32bit, errori v86d e VBE, poi login ok, vede ethernet ma non il wifi, il resto a posto
- 8.10 RC 64bit, errore I/O dev/sr0, si blocca.
con la 8.10 desktop i386 l'istallazione
va liscia, tutto a posto tranne ovviamente il wifi. (particolare: l'iso del live cd non c'entrava in un cd da 700 MB, mi ci e' voluto un DVD...).
attivati i driver nvidia 177 anche gli
effetti video sono a posto. gli altri
aggiornamenti automatici li fa da subito.
dimenticavo di dire che in uno scatto d'ira ho 'seccato' totalmente windows vista home precaricato ed ho assegnato l'intero disco a linux... tanto avevo provato a reinstallare win dai cd (12!!?!) di recupero che avevo fatto il primo giorno... ma si e' bloccato dopo piu' di 2 ore e quasi alla fine..... roba da matti...
per tentare di far funzionare il wireless ho seguito i vari forums (o
'fori'...) ed ho iniziato con:
$ sudo apt-get install ndiswrapper-common
$ sudo apt-get install linux-backports-modules-intrepid
(forse il ndiswrapper non servirebbe)
poi ho messo in blacklist i driver
preesistenti:
$ gksudo gedit /etc/modprobe.d/blacklist
aggiungendo le righe
blacklist ath_hal
blacklist ath_pci
poi ho disattivato il driver preesistente 'support for atheros 802.11 wireless lan cards' ed ho attivato il nuovo 'support for 5xxx series of atheros 802.11 wireless lan cards'.
a questo punto la scheda wifi la vede ma.... non e' accesa. solo per un
istante sono riuscito a vedere le reti
presenti, ma non si collegava. poi al
riavvio successivo non ha visto piu' nulla.
al momento sto cercando una maniera per
accendere il wifi (che su questo modello di portatile purtroppo e' comandato dal pulsantino vicino alla tastiera, e il led e' sempre rosso anche se lo premi). alcune soluzioni che sembrano funzionare risalgono a prima della release ufficiale di intrepid, quindi non vorrei pasticciare e preferisco aspettare una soluzione 'pulita'.
forse chi ha lasciato il dual boot con win e linux puo' provare a fare in modo che win all'uscita non spenga il wifi come sembrerebbe che fa, e passare dall'uno all'altro avendolo acceso.
c'e' qualcun altro che puo' farla questa prova?
aloha.

silvano ha detto...

un'ora dopo il mio ultimo post ho scoperto
una cosa abbastanza strana: il wifi di questo portatile si accende anche con intrepid, ma solo se si sta attenti a come si preme il pulsantino...... ne' troppo a lungo, ne' troppo rapidamente.
strano, ma a me succede cosi'.
ora le reti wifi le vedo, ma c'e' da
migliorare il bit rate... pero'... una
cosa alla volta.
ho messo una discussione su questo punto:
http://forum.ubuntu-it.org/index.php/topic,232030.0.html

mauro_paternò, of course! ha detto...

[Rieditato il post di prima che conteneva una imprecisione]
Ho installato nel frattempo anche io Intrepid Ibex, e sono riuscito ad installare e configurare i driver della scheda wireless seguendo la differente procedura riportata in questa pagina:

http://www.baretto.eu/atheros-ar5007eg-con-madwifi-su-ubuntu/

Spero che ti possa essere di aiuto.
Ciao.

Doctor Jypo ha detto...

Caro Mauro, grazie mille per questo post che mi rincuora. Ho comprato per necessità economiche questo portatile ed ho provato la stessa pesantezza usando Vista (maddai...) relegandola in uno spazio ancora più ridotto (29GB, sono stato cattivo). Ci ho montato prima un Ubuntu Hardy e poi (quello da cui ti scrivo) una delle più recenti versioni di Mepis. La configurazione attuale mi dà purtroppo notevoli problemi (HAL mi si pianta dopo 5 minuti che la macchina gira e la rete wireless deve essere riconnessa con la stessa frequenza). Dopo aver letto il tuo post, tornerò a Ubuntu senza stare a ricomprare un altro portatile (cosa che ero ormai sul punto di fare). Sappi che nei prossimi giorni ti ricontatterò per avere info!
Saluti
Alberto